Cloudflare Outage
Resolved
Nov 18 at 11:29am EST
The global Cloudflare outage appears to be resolved, and access to Credence is now fully restored.
You should be able to log in and use Credence without any further disruption.
Affected services
Updated
Nov 18 at 09:40am EST
The global Cloudflare outage, which was disrupting access to Credence, appears to be resolved for some, but not all users. Service is still degraded.
We appreciate your patience during this disruption.
Affected services
Created
Nov 18 at 08:35am EST
Access to Credence is currently disrupted due to a global outage affecting Cloudflare, our provider for cybersecurity services.
Credence will become fully accessible once Cloudflare restores its systems.
You can monitor Cloudflare's progress here: https://www.cloudflarestatus.com/
We apologize for the inconvenience and are monitoring this external issue closely.
Affected services